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1. Introduction 

The Vessel Editor application is designed to create and modify survey vessel definitions, as well as 
provide 3D visualization of the survey vessel. The vessel definition contains basic physical dimensions of the 
vessel, a collection of sensors, either mounted rigidly on the vessel's hull, or towed underwater by cables, and 

the set of appearance settings controlling vessel display in SonarWiz 5. 

2. User interface overview 

2.1. General 

Upon starting the application in standalone mode from the Start menu, the following interface will show 

up: 
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Illustration 1: Vessel Editor interface. It contains following sections: 

1.  Vessel property manager used to enter vessel name, description, physical dimensions, reference point and display 

options. 

1.1. Vessel top-down plan view. 

1.2. Vessel profile v iew. 

2. Vessel 3D view. 

3. Sensor list. 
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Vessel properties are entered in property manager located on the left side of the screen (1). Vessel 

dimensions and reference point position are entered on plan (1.1) and profile (1.2) views, in the upper portion of 
vessel property manager (1).  

On the plan view vessel length and width, as well as bow break distance and X/Y coordinates of reference 
position (RP) (e.g. the position of your GPS antenna) can be entered: 

 

On the profile view, vessel height, waterline offset and Z coordinate of reference position can be entered:  

 

Vessel physical dimensions and reference point position are entered in meters by default, but other unit s of 
measure can be selected if necessary (see 2.4). 

 

Illustration 2: Vessel plan view 

Illustration 3: Vessel profile view 
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Note that waterline height is measured when vessel is static. Additional vertical offset of the vessel moving 

at survey speed called squat can be entered under Appearance tab. Like waterline height, it is positive number. 

 

Another notable setting in vessel appearance tab is outline color, which determines color of vessel contour 
in 2D and 3D view. All other settings can be modified in the Vessel Editor, but do not affect vessel display in 2D 
views or 3D view – these values are used in SonarWiz itself.  

“Keep vessel centered” checkbox, when checked, will ensure that the vessel is always in the center of the 
Map window of SonarWiz so that the vessel does not “drive off” the screen.  

“Bow line” checkbox, when checked, will activate projected bow line in Map window which is given a 
true scale length (entered in numeric up-down beside the checkbox) in order to assist the visualization of the 
ship heading. 

“Draw mode” dropdown defines how vessel size will be interpreted in the ship graphic on the Map 
window. It may be drawn to true scale based on the dimensions entered or at fixed size regardless of scale.  

“Vessel size” dropdown contains three predefined fixed sizes of vessel regardless of map scale (Small, 
Medium, or Large). 

“Heading angle source” dropdown allow to choose whether to display the vessel heading base on either 

calculated fixto- fix Course Made Good or True Heading if that is being received by SonarWiz. 
 

When the Vessel Editor application is started in standalone mode, new vessel with default properties is 
automatically created for modification. To load existing vessel to edit, use 'File → Load Vessel' or CTRL+O 
keyboard shortcut. The following dialog will open up: 

Illustration 4: Vessel appearance settings 
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System-level vessels are highlighted with gray color. System-level vessels cannot be modified – all 
changes made to the system vessel will be saved as a new user- level vessel. To save changes to the vessel, use 

“File → Save Vessel” menu or CTRL+S shortcut. If a vessel file for new vessel already exists, the application 
will prompt to either rename the vessel, or overwrite existing one. Note that when the vessel name is changed in 
property manager, the vessel will be treated as new vessel.  

 
“Help → About” menu item will show about dialog containing brief information about application: 

 
 

Illustration 5: "Open vessel" dialog 

Illustration 6: "About Vessel Editor" dialog 
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2.2. Sensors 

Sensor list is located in the lower right part of application's window: 

 

Each sensor is marked with a colored icon (first column of the grid) matching its color in the 3D view 
(see 2.3). Create, update and delete operations with sensors, are available through a context menu on right 
mouse button click. If table header or emp ty list were clicked, only “New sensor...” option will be available.  

 

Another way to edit an existing sensor is to double-click the corresponding row in the grid.  

Illustration 7: Sensor list 

Illustration 8: Context menu in sensor list 
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After “New sensor” or “Edit sensor” options have been selected, the following dialog will show up: 

 

Sensor name should be unique within the scope of single vessel, and is a required field. Sensor 
description can be left empty. Available sensor classes are listed in Table 1. Sidescan, Subbottom and 

SwathBathy sensors are unique in the scope of vessel (but not mutually exclusive), i.e. a vessel can contain only 
one Sidescan, one Subbottom and one SwathBathy sensor. Sensor Priority is relative to other sensors of the 
same class for selection into the merge process and its values are in the range of 1 to 5. Certain sensors can be 

towed under-water, instead of being rigidly mounted on the vessel's hull. For this purpose, there is a special 
sensor class called CableMeter, which represents tow cables. “Towed by” dropdown is populated with the list 

of CableMeter sensors located on the currently open vessel. Note that CableMeter sensors which are already 
used to tow other sensors, cannot be deleted or have their class changed, until all dependent sensors have been 
modified to no longer be towed by the cable in question or deleted. Not all sensors can be towed (see Table 1), 

so the aforementioned dropdown is enabled only for sensors which can be towed. Sensor position is determined 
by its relative offset from the vessel's reference point (RP), except of towed sensors. For towed sensors, offset it 

taken from their respective tow cable's position instead of the reference point. 

Sensor offsets from reference point or cable are entered in meters by default, but another unit of measure 
can be selected if necessary (see 2.4). 

 

Illustration 9: Sensor edit dialog. Since new sensor is being created, all 

inputs are initialized with default values. 
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Angular offsets represent alignments (deviations) of the sensor with respect to the 3 main perpendicular 
X,Y, and Z axes of the vessel. These offsets can be edited only for SwathBathy sensors and are measured in 

degrees. For all other sensor classes angular offsets will always have default value of 0. 

 

Sensor class Instance restrictions Can be 

towed 

Sidescan Only 1 permitted Yes 

Subbottom Only 1 permitted Yes 

SwathBathy Only 1 permitted Yes 

Position Multiple allowed No 

Fathometer Multiple allowed Yes 

Magnetometer Multiple allowed Yes 

MotionSensor Multiple allowed Yes 

CableMeter Multiple allowed No 

Table 1: Sensor classes and their properties 

 

Illustration 10: Angular offsets for SwathBathy sensor 



VesselEditorManual.PDF                    Chesapeake Technology, Inc., copyright 2013-2014 

5.06.0032 release, 8/30/3013 support@chesapeaketech.com 650-967-2045 Page 9 

 

2.3. 3D visualization 

All changes made to vessel physical dimensions, reference position or the sensor list, are immediately 
applied to 3D view. Coordinate origin of vessel 3D model is always set to vessel's reference point position. 

Camera in 3D view can be controlled by mouse and keyboard. PageUp/PageDown keys, scrolling with mouse 
wheel, or dragging with middle mouse button will zoom scene out or in. Arrow keys or dragging with left 
mouse button will rotate vessel around X or Z axis (LEFT ARROW and RIGHT ARROW around Z axis, UP 

ARROW and DOWN ARROW around X axis). Vessel 3D model can be panned by dragging it with middle 
mouse button, or with W, Z, A, S keys to move vessel up, down, right or left accordingly.  

Every time new sensor is selected in the sensor list it will be marked with an arrow in 3D view, and its 
shape will be put on top of everything else: 

 

 

Illustration 11: Selected sensor in 3D view 
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Even when selected sensor is off screen, arrow will remain on screen, pointing to the approximate 

location of the sensor, to make it easier to pan it into view: 

 

This selection can be cleared with ESC key while either 3D view or sensor list grid are focused.  

There are two buttons at the top of 3D view used to set camera to display vessel in top-down plan view, 
or in profile view. Keyboard shortcuts ('t' for profile view and 'r' for plan view) are avalilable for this function as 

well. Colors for different sensor types can be configured in Application Settings dialog (see 2.4).   

Semi- transparent green surface that can be seen on screenshots represents water surface, and its color (as 

well as color of vessel mesh surface) can be configured via Application Settings as well. Outline color is taken 
from outline color vessel property (see 2.1). 

Illustration 12: Selected sensor is located off-screen 
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2.4. Application settings 

Application settings and graphics settings can be accessed through “Settings → Application Settings” 
and “Settings → Graphics” settings menu items accordingly, with F2 shortcut for graphics settings.  

Application settings dialog looks like this: 

 

It allows the user to choose background color for 3D view, color for scale division labels, the selected 

sensor captions and bounding box, measurement units for physical dimensions and offsets, colors for different 

sensor types, the colors for vessel surface and waterline, and other various vessel rendering settings. “Show 

bounding box”, “Show coordinate axes” and “Show rotation rings” checkboxes control display of the 

vessel's bounding box (built around vessel and its sensors including underwater ones) and scale divisions, X, Y 

and Z coordinate axes, and rotation indicators around X and Z axis respectively. “On-scene label color” setting 

controls color of bounding box outline, scale division labels, arrow border and label for selected sensor 

highlighting. “Center view on selected sensor” checkbox controls camera behavior on sensor selection – if 

checked, 3D view will be automatically centered on sensor when it is selected in the sensor list.  

Illustration 13: Application settings dialog 
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In the screenshot below, there is a 3D view with rotation rings enabled, and different background and 

text colors: 

 

“Measurement unit” dropdown allows you to select units, to enter physical dimensions and offsets in. 

The dimensions can be entered in meters, international feet or US feet. When different units are selected, all 

coordinate and dimension values will be automatically translated into the new units. Default measurement units 

are meters. 

“Vessel color” button allows you to select a color for the vessel surface. Default value is 

semitransparent white with alpha value of 191. Opaque color can be selected if desired, but it's not 

recommended since sensors mounted inside the vessel would not be visible, unless selected in sensor list. 

“Waterline color” button allows the user to select color of waterline in 2D and 3D view. 

In “Sensor colors” group colors for individual sensor classes can be selected. Both sensor shape itself 

Illustration 14: Vessel 3D view with different background and text color 
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(sphere for rigidly mounted sensors and octahedron for towed sensors) and background of the arrow indicating 

selected sensor will be filled with color for corresponding sensor class.  
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By default, the vessel is drawn as a solid-color semitransparent mesh with wireframe outline, but this 

setting can be changed to either solid shape only, or wireframe only. In the screenshot below, the 3D view with 

solid shape vessel is depicted: 

 
Illustration 15: Vessel drawn as solid shape 
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The vessel drawn as wireframe is depicted below. Note that water surface is not drawn in this mode – 

only waterline on the vessel's wireframe is visible.  

 

 

Illustration 16: Vessel drawn as wireframe outline 
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The graphics settings dialog allows you to set „back buffer‟ and „depth buffer‟ format, as well as enable 

or disable anti-aliasing. 

 

Illustration 17: Graphics settings dialog 


